Problems with inbound customer service calls

Incident Report for Virta

Resolved

Root cause has been found and fixed. Phone lines are working again normally.
Thank you for your patience and and apologies for the inconvenience.
Posted Dec 02, 2025 - 13:49 EET

Update

Our partner is continuing fixing the issue with the highest priority.
Posted Dec 01, 2025 - 16:41 EET

Identified

Our EV driver support call center provider has connectivity issues, which are causing some inbound calls to fail.
Our partner is currently investigating the problem.
Posted Dec 01, 2025 - 12:22 EET
This incident affected: Telecommunication.