Degrated performance in showing customer information in Virta HUB

Incident Report for Virta

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 18:31 EEST

Identified

We experienced some degradation in Virta HUB when trying to show the customer information. We found the root cause and are trying to fix it. We apologise for the inconvenience caused.
Posted Jun 26, 2025 - 18:13 EEST
This incident affected: Virta Hub.