Degrated performance in showing customer information in Virta HUB

Incident Report for Virta

Resolved

Following our investigation, the problem has been found and solved.
Posted Jul 08, 2025 - 10:27 EEST

Investigating

We are experiencing some degradation in Virta HUB when trying to show the customer information. The investigation is on-going to find the root cause.
We will provide an update once the root cause is found.
We apologise for the inconvenience caused.
Posted Jul 08, 2025 - 08:31 EEST
This incident affected: Virta Hub.