Problems with inbound customer service calls with Swedish support line

Incident Report for Virta

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 14:07 EEST

Investigating

Our customer service provider is facing problems with inbound customer service calls with Swedish support line.
Service provider is currently investigating the cause.

As a workaround please use English support phone line.
+442081062497

Thank you for your patience.
Posted Apr 17, 2026 - 10:52 EEST
This incident affected: Telecommunication.